忍不住装 Firefox 4.0 Beta3 了

之前一直想忍着等正式版来着…
看见 cnBeta 上某篇文章后,实在忍不住了…

即使是 Beta 也有官方简体中文版,下载页面也是中文的,不错…

安装路径默认不与 Firefox 3.x 重复,但手工改为同一目录后,安装程序提示将“升级”程序:
Firefox 4.0 b3 安装界面

升级后,原来的所有设置、小甜饼们(Cookies)、收藏夹什么的全都保留。
书签栏默认不显示,可以通过 Firefox->定制->书签工具栏 启用。与大多 Windows 程序一样,按下 Alt 键可以临时显示菜单栏。
标签栏放在顶部后,总习惯按 Chrome 的操作方式,点标签右侧新建标签…结果每次都点空… -_-|||

当然,扩展什么的还是全部被禁用了:
扩展全被禁用

火狐对于没标记为兼容此版本的扩展,一律默认当作不兼容。其实,其中的一些扩展还是可以继续使用的。
可以在地址栏输入 about:config,进入设置页面
右键新建项:名称为 extensions.checkCompatibility.4.0b,类型为 布尔型,值为 false
设置立即生效,重启以后插件生效:

试了一下,扩展 Save Flash Movie 0.9.0.6 将导致悲剧发生:UI恢复为 3.x 形式,扩展页面无法打开……需要进入安全模式禁用此扩展恢复…
很实用的 AutoProxy 0.3b4.0 将没有效果,成为装饰品; Updata100819: 新版 AutoProxy 0.4b1 支持 Firefox 4.0b4 了!~
IE Tab 1.92 切换为IE后,将显示缺失插件,无法使用..还是老老实实开IE吧…
FireBug 1.5.4 无法使用..界面死都出不来…
Download Statusbar 0.9.7 无反应,无法使用…

好在,Adblock PlusXmarksGoogle Translator for FirefoxAutoPager 等一批扩展,虽然不同程度地残疾了,但还是坚强地活了下来……

如果你严重依赖这些扩展…升级什么的还是三思吧…

Updata100825: 除了自身扩展,还会导致 MediaCoder 出现问题!MC 在向导、一些设置等弹出式窗口中使用了 Fx 的 XUL,新版本号改为2.0b,MC 就不认报错了… -_-||

发表评论

电子邮件地址不会被公开。 必填项已用*标注